Marketplace Issues
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Nov 05, 2020 - 12:40 PST
Investigating
We are aware that Residents are experiencing issues logging in, and seeing some delays, while trying to access the Second Life Marketplace. Our teams are investigating. Please monitor this blog for updates.
Posted Nov 05, 2020 - 11:05 PST
This incident affected: Websites (marketplace.secondlife.com) and Second Life Services (Marketplace Purchases).