Marketplace Maintenance

Incident Report for Second Life

Resolved

Marketplace maintenance has now finished.
Posted Jun 21, 2023 - 14:03 PDT

Identified

We are currently performing Marketplace maintenance During this period, the Second Life Marketplace will be temporarily inaccessible. Please watch this blog for updates.
Posted Jun 21, 2023 - 11:53 PDT
This incident affected: Websites (marketplace.secondlife.com).