Unscheduled Live Chat Maintenance

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Jan 12, 2021 - 08:41 PST

Investigating

We are currently investigating Live Chat support issues. During this time, Live Chat may be slow to respond or experience other issues. Please monitor this blog for updates.
Posted Jan 12, 2021 - 07:50 PST
This incident affected: External Support (Chat Support).