Concierge Phone and Chat Support Unavailable
Incident Report for Second Life
Resolved
This scheduled maintenance has been completed.
Posted 27 days ago. Aug 25, 2018 - 12:15 PDT
Investigating
All phone and live chat support will be unavailable from 10:00 AM PDT to 11:00 AM PDT today. Ticket submissions will still be available at this time.
Posted 27 days ago. Aug 25, 2018 - 09:18 PDT
This incident affected: External Support (Chat Support, Phone Support).