Second Life - Log In Issues
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 19 days ago. Oct 29, 2018 - 08:59 PDT
Update
We are continuing to investigate this issue. Residents may still experience inability to log in, or other connection issues. Watch this blog for further updates.
Posted 20 days ago. Oct 28, 2018 - 14:16 PDT
Investigating
We are currently experiencing issues with log ins that is currently being investigated. Residents may experience log outs at this time. Please continue to check this blog for updates.
Posted 20 days ago. Oct 28, 2018 - 08:18 PDT
This incident affected: Second Life Services (Logins).