My.secondlife.com Outage
Incident Report for Second Life
Resolved
My.secondlife.com is now available. Thank you for your patience!
Posted Jul 28, 2021 - 15:05 PDT
Investigating
My.secondlife.com is currently unavailable. While we work to bring this service back online, both my.secondlife.com and in-world profiles will be inaccessible.

We will update this blog when this web service has been restored.
Posted Jul 28, 2021 - 14:38 PDT
This incident affected: Websites (my.secondlife.com) and Inworld Services (Profiles).