Beta Grid Login Issues
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Nov 16, 2022 - 06:13 PST
Investigating
We are aware that some residents are having trouble logging into the beta grid, Aditi. We are currently investigating this issue further.

Please follow this blog for updates.
Posted Nov 12, 2022 - 10:05 PST
This incident affected: Second Life Services (Logins).