Marketplace Issues
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Oct 28, 2020 - 12:07 PDT
Investigating
We are aware that Residents are experiencing issues logging in, and seeing some delays, while trying to access the Second Life Marketplace. Our teams are investigating. Please monitor this blog for updates.

Thank you for your patience during this time.
Posted Oct 28, 2020 - 11:51 PDT
This incident affected: Websites (marketplace.secondlife.com).