International Transaction Issues
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Jul 13, 2020 - 17:17 PDT
Investigating
We are aware of an issue that may cause some of our international resident's transaction attempts to fail. We are currently investigating this matter. Please monitor this blog for updates.
Posted Jul 13, 2020 - 14:51 PDT
This incident affected: Inworld Services (L$ Transactions) and Second Life Services (Marketplace Purchases).