Phone and Chat support Unavailable
Incident Report for Second Life
Resolved
Concierge live phone and chat support are now available.
Posted 3 months ago. Dec 09, 2016 - 12:51 PDT
Investigating
Phone and chat support will be unavailable from 12:00 noon to 1:00 PM PST December 9th, 2016. Case submissions are still available.
Posted 3 months ago. Dec 09, 2016 - 12:04 PDT
This incident affected: External Support (Chat Support, Phone Support).