Unscheduled Phone Support Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 10:08 PDT
Investigating
Billing, Premium Pus, and Concierge Support Phones are undergoing unscheduled maintenance. While this is in progress, some callers may be disconnected or be unable to connect. We apologize for the inconvenience; please watch this blog for updates.
Posted Apr 22, 2024 - 08:40 PDT
This incident affected: External Support (Phone Support).