Premium and Concierge Live Chat Closed
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 3 months ago. Dec 27, 2016 - 09:13 PDT
Monitoring
Premium and Concierge Live Chat services are closed today, December 26th.

For Premium and Basic users, billing concerns may be addressed through our Billing Phone Support: https://support.secondlife.com/billing-support/

For Concierge users, Concierge Support can be reached through Concierge Phone Support.

For all requests, you may submit support requests through a support case, which is available 24 hours a day, 7 days a week: https://support.secondlife.com/

Premium and Concierge Live Chat services will be reopened tomorrow, December 27th. Happy Holidays!
Posted 3 months ago. Dec 26, 2016 - 07:38 PDT
This incident affected: External Support (Chat Support).