Holiday Support Hours
Incident Report for Second Life
Resolved
Premium and Concierge Live Chat services are now available
Posted 10 months ago. Jan 03, 2017 - 05:39 PST
Monitoring
Beginning December 28th, Premium and Concierge Live Chat services will be closed until January 3rd, 2017.

For Premium and Basic users, billing concerns may be addressed through our Billing Phone Support 24 hours a day, 7 days a week: https://support.secondlife.com/billing-support/

For Concierge users, Concierge Support can be reached through Concierge Phone Support during normal business hours (5:00AM-3:00PM PST). Please note that Concierge Phone Support will also be closed December 31st and January 1st to allow our staff time off to ring in the New Year.

For all requests, you may submit support requests through a support case, which is available 24 hours a day, 7 days a week: https://support.secondlife.com/
Posted 10 months ago. Dec 27, 2016 - 17:52 PST
This incident affected: External Support (Chat Support, Phone Support).