Login Issues
Incident Report for Second Life
Resolved
This issue has been resolved! If you in Germany and are still experiencing log-in issues, please contact our support team via chat or ticket for assistance.
Posted 2 months ago. Aug 08, 2018 - 10:28 PDT
Investigating
Some German residents are currently experiencing login issues. These appear to specific to particular Internet Providers. If you are unable to log in from Germany, please contact your Internet Provider for assistance.
Posted 3 months ago. Jul 29, 2018 - 10:24 PDT
This incident affected: Second Life Services (Logins).