Linden Home Selection
Incident Report for Second Life
Resolved
We have resolved the issue that was impacting some residents while selecting a Linden Home. We thank you for your patience.
Posted 13 days ago. Oct 02, 2018 - 15:38 PDT
Investigating
We are aware that some residents are having issues selecting a Linden Home. We are working on a solution so please keep an eye on this page for updates
Posted 13 days ago. Oct 02, 2018 - 14:57 PDT