Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
The unscheduled maintenance has been resolved.
Posted 19 days ago. Sep 07, 2017 - 14:55 PDT
Investigating
We are performing unscheduled maintenance on our billing system. While this maintenance is in progress, credit card processing may be affected for some users. Please check this blog for updates.
Posted 19 days ago. Sep 07, 2017 - 13:31 PDT
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases).