Phone and Chat Support Unavailable
Incident Report for Second Life
Resolved
The scheduled maintenance has been completed.
Posted about 2 months ago. May 05, 2017 - 13:00 PDT
Monitoring
Phone and chat support will be unavailable from 12:00 noon to 1:00 PM PDT, May 5, 2017. Case submissions are still available.
Posted about 2 months ago. May 05, 2017 - 11:28 PDT
This incident affected: Second Life Regions (Second Life Main Channel Regions, Second Life RC LeTigre Regions, Second Life RC BlueSteel Regions, Second Life RC Magnum Regions, Second Life RC Snack Regions, Second Life RC Cake Regions).