Unscheduled Auction Maintenance
Incident Report for Second Life
Resolved
The Unscheduled Auction Maintenance has been resolved. We thank you for your patience.
Posted 22 days ago. Apr 29, 2018 - 06:05 PDT
Investigating
We are currently performing unscheduled maintenance on our auction system. While this maintenance is underway, our auctions page (https://usd.auctions.secondlife.com) may not be available. Please watch this blog for further updates.
Posted 23 days ago. Apr 28, 2018 - 08:08 PDT
This incident affected: Websites (secondlife.com).