Phone and Chat support Unavailable
Incident Report for Second Life
Resolved
[Resolved 1:00 PM PsT, 2 December 2016] Concierge live phone and chat support are now available.
Posted 8 months ago. Dec 02, 2016 - 13:00 PST
Investigating
[Posted 12:00 Noon PST, 2 December 2016] Phone and chat support will be unavailable from 12:00 noon to 1:00 PM PST December 2, 2016. Case submissions are still available.
Posted 8 months ago. Dec 02, 2016 - 12:02 PST