Unscheduled Maintenance For Search Services
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 13, 2017 - 20:43 PDT
Investigating
We are currently investigating this issue.
Posted 4 months ago. Jul 13, 2017 - 18:46 PDT
This incident affected: Websites (search.secondlife.com).