Some Weekly Premium Stipends Delayed
Incident Report for Second Life
Resolved
This issue has been resolved. This week's Premium stipends have been paid. Please check your $L balances.
Posted 8 months ago. Oct 31, 2017 - 09:45 PDT
Investigating
We are aware that some residents Weekly Premium Stipends have been delayed. We are in the process of getting those out. We will update this blog when that has been completed. Thank you for your patience!
Posted 8 months ago. Oct 31, 2017 - 06:17 PDT