Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
The unscheduled maintenance has been completed.
Posted 17 days ago. Nov 02, 2017 - 18:32 PDT
Investigating
We are performing unscheduled maintenance at approximately 6:00 PM PDT. While this maintenance is in progress, our billing services, including LindeX and Marketplace, may not be available. Credit card processing may be affected during this time as well. Please check this blog for updates.
Posted 17 days ago. Nov 02, 2017 - 18:00 PDT
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases, Process Credits).