Phone Support Unavailable
Incident Report for Second Life
Resolved
Live phone support is now available.
Posted about 1 month ago. May 15, 2017 - 14:01 PDT
Investigating
Our telephone service provider is experiencing temporary technical issues at their data center. During this outage, both Billing and Concierge Phone Support will remain unavailable. We apologize for this inconvenience. Please monitor this blog for additional updates.
Posted about 1 month ago. May 15, 2017 - 12:33 PDT
This incident affected: External Support (Phone Support).