Live Chat and Concierge Phone Support Closed Christmas
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 7 months ago. Dec 26, 2016 - 07:28 PST
Monitoring
Live Chat Support and Concierge Phone Support will be closed Sunday, December 25th to allow our staff to spend time with their families. We will resume Concierge Phone Support the following day on Monday, December 26th.

Support case submission remains available 24 hours a day, 7 days a week. To submit a support case, please visit https://support.secondlife.com/

Happy Holidays!
Posted 7 months ago. Dec 24, 2016 - 18:22 PST
This incident affected: External Support (Chat Support, Phone Support).