Phone and Chat support Unavailable
Incident Report for Second Life
Resolved
Concierge live phone and chat support are now available.
Posted 10 months ago. Dec 15, 2016 - 10:42 PST
Investigating
Phone and chat support will be unavailable from 10:00 AM to 11:00 AM PST December 15th, 2016. Case submissions are still available.
Posted 10 months ago. Dec 15, 2016 - 09:31 PST
This incident affected: External Support (Chat Support, Phone Support).