Unscheduled Voice Server Maintenance
Incident Report for Second Life
Resolved
The Unscheduled Maintenance for the Voice Server has been completed.
Posted 13 days ago. Nov 29, 2017 - 15:53 PST
Investigating
We are currently looking into issues with in-world voice functionality. We appreciate your patience while we investigate.
Posted 14 days ago. Nov 29, 2017 - 15:10 PST