Concierge and Billing Phone Support Unavailable
Incident Report for Second Life
Resolved
Concierge phone and Billing phone support are open.
Posted 26 days ago. Jun 29, 2017 - 12:59 PDT
Identified
Concierge phone and Billing phone support will be unavailable from 12:15 noon to 1:00 PM PDT, June 29th, 2017. Case submissions are still available.
Posted 26 days ago. Jun 29, 2017 - 12:19 PDT
This incident affected: External Support (Phone Support).