Unscheduled Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 5 months ago. Jun 29, 2018 - 12:31 PDT
Investigating
We are currently undergoing unscheduled maintenance at this time. Some users may experience temporary issues when logging in, teleporting, or using voice chat during this maintenance period. We appreciate your patience while during this time.
Posted 5 months ago. Jun 29, 2018 - 11:41 PDT
This incident affected: Second Life Services (Logins) and Inworld Services (Voice Chat, Teleports).