Weekly Premium Stipends Delayed
Incident Report for Second Life
Resolved
Thank you for your patience. Stipends have been distributed! Please check your Linden$ balance - if you have still not received your stipend, please feel free to reach out through Live Chat, or submit a Support Case.
Posted 7 months ago. Jan 23, 2018 - 09:24 PST
Update
Thank you for your continued patience. We are currently dispersing the remaining stipends. We will provide additional updates as they become available.
Posted 7 months ago. Jan 23, 2018 - 06:31 PST
Investigating
We are aware that some residents Weekly Premium Stipends have been delayed. We are in the process of getting those out. We will update this blog when that has been completed. Thank you for your patience!
Posted 7 months ago. Jan 23, 2018 - 05:31 PST