Scheduled Billing Maintenance
Incident Report for Second Life
Resolved
Our scheduled billing maintenance has been completed.
Posted 5 months ago. Jun 26, 2017 - 12:06 PDT
Update
Today's scheduled billing maintenance is still in progress. Please continue to watch this blog post for updates.
Posted 5 months ago. Jun 26, 2017 - 11:45 PDT
Identified
We will be performing maintenance on our billing system today, Monday June 26th, beginning at approximately 10:00 AM PDT. While this maintenance is in progress, our billing services, including LindeX and Marketplace, may not be available. Credit card processing may be affected during this time as well. Please check this blog for updates
Posted 5 months ago. Jun 26, 2017 - 09:12 PDT
This incident affected: Inworld Services (L$ Transactions).