Concierge and Billing Phone Support and Live Chat Unavailable
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 19 days ago. Nov 24, 2018 - 11:43 PST
Investigating
Concierge phone and chat support will be unavailable from 10:30 AM PDT to 11:30 AM PDT today, November 15th, 2018. Ticket submissions will still be available at this time.
Posted 19 days ago. Nov 24, 2018 - 08:31 PST
This incident affected: External Support (Chat Support, Phone Support).