Second Life Email Notifications
Incident Report for Second Life
Resolved
Email notifications are working as intended again.
Posted about 2 months ago. Mar 29, 2019 - 09:35 PDT
Investigating
As we are currently working to resolve issues with email notifications for some Second Life residents, please see our community blog for details regarding the issue: https://community.secondlife.com/blogs/entry/2467-update-on-email-notifications-from-second-life. Thank you for your continued patience, and please refer to this blog for any further updates.
Posted 4 months ago. Jan 14, 2019 - 07:21 PST