Unscheduled Maintenance to LSL Scripts
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Oct 01, 2021 - 12:53 PDT
Update
We believe we have a fix ready for this issue!

We will be rolling it out to a small number of regions on the main grid tonight as a test, and to gather data. If we're able to collect enough data overnight that says that the fix works properly, we'll roll it out across the entire main grid on Friday morning. (PDT)

Thanks for hanging in there with us today.
Posted Sep 30, 2021 - 20:31 PDT
Update
A bit more detail on what’s going on from April Linden:

This morning one of the root certificates for the very popular (and cool!) Certificate Authority called “Let’s Encrypt” expired. Let’s Encrypt is neat because they give away encryption certificates to anyone for free, with the goal of making the Internet more secure overall. Since they’re free, lots of folks use them to help secure their websites all over the globe.

This certificate expiring impacted Second Life in a way we did not expect. As of right now inworld LSL scripts making HTTP calls to websites secured with a Let’s Encrypt certificate are failing.

Our engineers are working hard to figure out why this certificate expiring had this effect, and how to fix it. This is an all-hands-on-deck problem until we get it fixed.

We’re sorry this is happening. We did not expect it to happen, but we’re working hard to fix it.

Thanks for bearing with us as we sort it out. Please keep on watching this blog for more updates as we figure out the best way to fix it.

-April
Posted Sep 30, 2021 - 15:21 PDT
Update
We are continuing to work on resolving this issue. Thank you for your patience during this time!
Posted Sep 30, 2021 - 13:25 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 30, 2021 - 10:02 PDT
Investigating
We are investigating reports of problems with LSL scripts communicating with sites secured with Let's Encrypt certificates. Please follow this blog for updates.
Posted Sep 30, 2021 - 09:12 PDT