Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
Our unscheduled billing maintenance has been completed.
Posted May 20, 2017 - 07:53 PDT
Investigating
We are currently performing unscheduled maintenance on our billing systems. While this maintenance is in progress, our billing services, including LindeX and Marketplace, may not be available. Credit card. PayPal, and Skrill processing may be affected during this time as well. Please check this blog for updates.
Posted May 20, 2017 - 07:03 PDT
This incident affected: Websites (marketplace.secondlife.com), Second Life Services (LindeX Purchases, Marketplace Purchases), and Inworld Services (L$ Transactions).