Billing Issues
Incident Report for Second Life
Resolved
This issue is now resolved - you should be able to transact normally with Mastercard. If you are still having issues, please contact support.
Posted 4 days ago. Jul 13, 2018 - 07:01 PDT
Investigating
We are currently investigating an issue that may cause some Mastercard transactions to fail. This may also prevent Mastercards from being added as payment methods. Please monitor this blog for updates.
Posted 4 days ago. Jul 12, 2018 - 11:13 PDT
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases).