Support closed for Labor Day September 4th
Incident Report for Second Life
Resolved
Basic, Premium and Concierge Live Chat and phone support is now open. Case submissions remain open as normal.
Posted 10 months ago. Sep 05, 2017 - 06:07 PDT
Investigating
In observance of Labor Day - Basic, Premium and Concierge Live Chat and phone support will be closed. Case submissions will remain open. All support channels will re-open Tuesday, September 5th at 5AM PDT.
Posted 11 months ago. Sep 01, 2017 - 13:39 PDT
This incident affected: External Support (Chat Support, Phone Support).