General Billing Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 12, 2017 - 18:21 PDT
Investigating
We are currently investigating this issue.
Posted 4 months ago. Jun 12, 2017 - 17:59 PDT
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases, Process Credits).