Unscheduled Maintenance for Process Credit Requests
Incident Report for Second Life
Resolved
The Unscheduled Maintenance for Process Credit Requests has been completed.
Posted 22 days ago. Nov 20, 2017 - 18:28 PST
Investigating
We are currently undergoing unscheduled maintenance for Process Credit Requests. Please refrain from initiating a *new* Process Credit request until further notice. Please check this blog for updates.
Posted 22 days ago. Nov 20, 2017 - 18:16 PST
This incident affected: Second Life Services (Process Credits).