Scheduled Billing Maintenance
Incident Report for Second Life
Resolved
Today's billing maintenance has been completed. You may now resume transacting within Second Life.
Posted 4 months ago. Dec 01, 2016 - 11:24 PDT
Identified
We will be performing scheduled maintenance on our billing system today, Thursday December 1st beginning at approximately 11:00 AM PST. While this maintenance is in progress, our billing services, including LindeX and Marketplace, may not be available. Credit card processing may be affected during this time as well. Please check this blog for updates.
Posted 4 months ago. Dec 01, 2016 - 10:37 PDT
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases).