Billing and Marketplace Issues
Incident Report for Second Life
Resolved
The issues impacting L$ and marketplace purchases have been resolved. You may once again purchase/sell L$, purchase items from the Marketplace and resume process credit requests.
Posted 3 months ago. Jan 03, 2017 - 08:22 PDT
Investigating
We are aware that many users are experiencing issues with L$ purchases and receiving Marketplace deliveries. During this time, please refrain from attempting to purchase L$, initiating process credits, and making purchases on the Marketplace. Please monitor this blog for additional updates.
Posted 3 months ago. Jan 03, 2017 - 05:38 PDT
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases, Process Credits).