Phone and Chat support Unavailable
Incident Report for Second Life
Resolved
Concierge live phone and chat support are now available.
Posted about 2 months ago. Feb 03, 2017 - 12:31 PDT
Investigating
Phone and chat support will be unavailable from 12:00 noon to 1:00 PM PST, February 3rd, 2017. Case submissions are still available.
Posted about 2 months ago. Feb 03, 2017 - 11:44 PDT
This incident affected: External Support (Chat Support, Phone Support).